The post implementation troubleshooting checks in this section include instructions on how to carry out the check, what the expected diagnosis is, and what action can be taken to remedy a problem found:
License Creation - Problem Exporting License
Action:
Open the Management Dashboard and navigate to System Setup > License. Click Generate.
A LicensePackage.zip file is generated.
Diagnosis:
| n | License is not exported. |
| n | Problem in the UI in the license exporting phase. |
Resolution:
Obtain the systemId manually:
#kubectl get cm system-config -n votiro -o yaml | grep systemId:
| 3. | Request a license by sending the systemId, customer details and the license expiration date, to Votiro support by email at support@votiro.com. Alternatively, generate a license using the Votiro license server. |
Test a File - File is blocked due to an Error in Positive Selection
Action:
Files with URLs may be blocked if the Virtual Appliance cannot reach the internet.
Diagnosis:
| n | Proxy is blocking access. |
| n | Geo location block in FW. |
| n | Any other networking issues. |
Resolution:
Disable Safebrowsing manually, using these steps:
| 2. | Use the following command: |
#kubectl edit cm system-config -n votiro -o yaml
| 3. | Set the value of parameter SafebrowsingIsEnabled: to False. |
| 4. | Restart the relevant pods, using the following command: |
- #kubectl get pods -n votiro | awk '/officex|office-|pdf|eml/{print $1}' | xargs kubectl delete -n votiro pod
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